Elevado tiempo de respuesta en witei.com
Incident Report for Witei
Resolved
La incidencia se ha resuelto.
Posted Oct 18, 2019 - 10:02 CEST
Investigating
We are currently investigating this issue.
Posted Oct 18, 2019 - 09:45 CEST