Valoraciones con UDA: servicio temporalmente no disponible
Incident Report for Witei
Resolved
El servicio de UDA se suspende indefinidamente.
Posted Oct 15, 2020 - 11:16 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 21, 2020 - 13:28 CEST